読者です 読者をやめる 読者になる 読者になる

超初心者のAndroidアプリ開発ノート

専業主婦、プログラミング経験0からのスタート!本とGoogleに頼って勉強中。分からないこと、調べたことを載せていきます。

61日目 "Gradle project sync failed. Basic functionality (e.g editing debugging)will not work properly." の解決策を探る

Q&Aに聞く前に、たっぷり寝た頭でもう一回エラーの内容と、今まで私が試した解決策を整理する。

状況

久しぶりにAndroidStudioをたちあげたら、次のエラー

Gradle project sync failed. Basic functionality (e.g editing debugging)will not work properly. 

f:id:hipopocroco:20150114230808p:plain

画面下のMassages Gradle Syncには

failed to find Build Tools revision 19.0.1

Please install the missing Build Tools from the Android SDK Maneger.

Open Android SDK Manager

f:id:hipopocroco:20150114230924p:plain

POINT

・数ヶ月ずっと使っていたのに突然出たエラー

Android Studioのバージョンをあげていない

 

試みてだめだった解決策 その1

メッセージにある通り、SDK Manegerを立ち上げて、19.0.1をインストールしようとすると、

Done.Nothing was installed.

f:id:hipopocroco:20150114231820p:plain

えー、すでにインストールされてるってこと???

ガ~~~ン。

試みてだめだった解決策 その2

掌田津耶乃さんのAndroid StudioではじめるAndroidプログラミング入門に書いてあった。Gradleのバージョンを上げる方法

↓プロジェクトWindowにある、gradle-wrappaer.propertiesをクリック

f:id:hipopocroco:20150114232833p:plain

↓赤印のところのバージョンを上げる

f:id:hipopocroco:20150114232908p:plain

次に

↓プロジェクトWindowにある、build gradleをクリックして

f:id:hipopocroco:20150114233243p:plain

↓丸印のバージョンを上げる

f:id:hipopocroco:20150114233257p:plain

やっぱり、ダメ~。違うエラーが発生。。。

それに、今までバージョンをかえてないのにこの解決策はなにか違う気がする。

きっと、バージョンが変わっていたならこのやり方は有効だと思うんだけど、、、、

 

試みた解決策 その3


How to fix : Gradle project sync failed (Android studio) - YouTube

これ、めちゃめちゃわかりやすい!!

これで解決したかった。でも、ダメだった。

このビデオでは、Android Support Repositoryをインストールしてから、SDKをインストールするやり方だったけれど、私のPCにはすでにインストールされていた。

f:id:hipopocroco:20150114234855p:plain

確かに、よく見ると、エラーの内容も若干違ってる

動画の画面下のMassages Gradle Syncには

failed to find build tools revision 19.1.0

install build tools 19.1.0 and sync project 

バージョンも同じだから、これで解決したかった。。。

ううーーん。分からない。

今日の終わりに

解決には至らなかったけど、分からないことを調べるキーワードが思い浮かぶのは多分昨日いっぱい寝たからかな。毎度毎度思うけど、日中にしっかり勉強したらもうちょっと能率は上がるんじゃないだろうか。

私の場合はダメでしたが、同じようにGradle project sync failed.で泣いた誰かの参考になれば幸いです。